View Issue Details

IDProjectCategoryView StatusLast Update
0012961mantisbtplug-inspublic2021-03-07 18:28
ReporterLapinkiller Assigned Todregad  
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.5 
Target Version2.25.0Fixed in Version2.25.0 
Summary0012961: Plugin_force_uninstall is not declared
Description

When uninstalling plugin,in manage_plugin_uninstall.php line 48, if $t_plugin is null it call method plugin_force_uninstall($t_basename) which doesn't exist...

Additional Information

I got this error because i make a mistake during the developement of a plugin,(the <plugin>/<Plugin>.php file was missing... so $t_plugin was null

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 0bb66f56

2019-05-04 12:00:56

dregad

Details Diff
Remove call to nonexistent plugin_force_uninstall()

This call has been present since manage_plugin_uninstall.php was
initially created, but the function has never been defined in Plugin
API.

Considering that having $t_plugin == null (supposedly meaning that the
plugin is not properly registered) is not a normal scenario, it makes
more sense to remove the call rather than creating the missing API.

Fixes 0012961
Affected Issues
0012961
mod - manage_plugin_uninstall.php Diff File