View Issue Details

IDProjectCategoryView StatusLast Update
0002464mantisbtotherpublic2006-04-20 06:24
ReporterreporterAssigned Tograngeway  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
PlatformAllOSAllOS VersionAll
Product Version0.17.5 
Summary0002464: Over general CSS
Description

The following code in css_inc.php ...

td { [edit] padding: 0px; [edit] }

... means that if anyone uses tables in $g_bottom_include_page and $g_top_include_page in /default/config_inc2.php, their tables are liable to explode. This is not a problem if they're just text in tables, but in a carefully made image spliced table graphic layout everything is ruined. The CSS is far too general. I know it's a pain to specify class="a_mantis_table" rather than just use a style allocated to all <td> but it really should be done if you plan for people to be able to use their own header and footer files.

I realise that this isn't a "bug" as such, but it certainly had me stumped for a while.

TagsNo tags attached.

Relationships

duplicate of 0004227 acknowledged Roadmap 1.0 - Templates 

Activities

reporter

reporter

2002-09-04 05:36

reporter   ~0003233

Sorry, that code example should read ...

td { [edit] padding: 4px; [edit] }

... not 0px as that was my change to correct the exploding table problem, however this now means all my Mantis tables are a little tight. The opposite view I suppose is that I should be setting classes for each of my header/footer tables and leaving the generalisation up to mantis.

vboctor

vboctor

2004-04-22 02:51

manager   ~0005412

I think both Mantis and your header/footers should use specialised styles. The easy way to do that in Mantis is to define the formatting of td/p/table/... when they are inside a

<div class="mantis">
...
<td> this automatically uses padding of 4 without specifying a class </td>
</div>

grangeway

grangeway

2006-04-17 12:06

reporter   ~0012550

Hello,

I think that this issue (if it still exists) is something best dealt with as part of the planned changes with regards to look/feel and templates.

Thanks
Paul

Issue History

Date Modified Username Field Change
2004-04-22 02:51 vboctor Note Added: 0005412
2006-04-17 12:06 grangeway Relationship added duplicate of 0004227
2006-04-17 12:06 grangeway Duplicate ID 0 => 4227
2006-04-17 12:06 grangeway Status new => resolved
2006-04-17 12:06 grangeway Resolution open => duplicate
2006-04-17 12:06 grangeway Assigned To => grangeway
2006-04-17 12:06 grangeway Note Added: 0012550
2006-04-20 06:24 vboctor Status resolved => closed