View Issue Details

IDProjectCategoryView StatusLast Update
0027303mantisbtcode cleanuppublic2020-09-25 14:53
Reporterdregad Assigned Todregad  
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Target Version2.24.3Fixed in Version2.24.3 
Summary0027303: When processing categories, it is not necessary to know the project id
Description

The project id can be retrieved from the category record, so using a form parameter is redundant and could potentially be inconsistent with the given category id.

The form parameter should be removed to simplify code and avoid confusion.

TagsNo tags attached.

Activities

dregad

dregad

2020-09-20 10:29

developer   ~0064461

Targeting 2.24.3, because this bundled in PR https://github.com/mantisbt/mantisbt/pull/1704

Related Changesets

MantisBT: master-2.24 13ae48bc

2020-09-20 10:29:08

dregad

Details Diff
Remove unnecessary project_id form parameter

When processing a single category, the project id can be retrieved from
the category record, so using a form parameter is redundant and could
be inconsistent with the category id.

Fixes 0027303
Affected Issues
0027303
mod - manage_proj_cat_delete.php Diff File
mod - manage_proj_cat_edit_page.php Diff File
mod - manage_proj_cat_update.php Diff File

Issue History

Date Modified Username Field Change
2020-09-20 10:28 dregad New Issue
2020-09-20 10:29 dregad Note Added: 0064461
2020-09-20 11:06 dregad Assigned To => dregad
2020-09-20 11:06 dregad Status new => assigned
2020-09-25 13:27 dregad Changeset attached => MantisBT master-2.24 13ae48bc
2020-09-25 13:27 dregad Status assigned => resolved
2020-09-25 13:27 dregad Resolution open => fixed
2020-09-25 13:27 dregad Fixed in Version => 2.24.3
2020-09-25 14:53 dregad Status resolved => closed