View Issue Details

IDProjectCategoryView StatusLast Update
0003736mantisbtplug-inspublic2014-12-08 02:18
Reportertazza70 Assigned Tovboctor  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Summary0003736: Implementing Themes
Description

It would be nice if Mantis was able to have better support for managing themes.

Tagsredesign

Relationships

duplicate of 0004227 acknowledged Roadmap 1.0 - Templates 
has duplicate 0003686 closedgrangeway Theme system using CSS and/or Smarty. 
has duplicate 0006671 closedryandesign Tracker themes, user selectable or not. 
has duplicate 0016666 closedatrol skins and themes for bugtracker 

Activities

tazza70

tazza70

2004-04-12 18:22

reporter   ~0005368

I understand there is some initial support (configuration path for CSS), but configuration options are in several different places:

  1. Separate CSS file needs to be created for custom colours
  2. Bug status colours need to be changed in the main configuration files
  3. Separate html file needs to be created and its path added to main configuration file to add a logo

It would be much easier if 1 and 2 were combined to be held in a single CSS file and 3 was part of the standard code, thus giving you the ability just to modify the image file as required.

An extra step would be maybe to enable management of themes per project through the database. While the above is probably not much work, this would be quite a bit of work. Another thing to think about here before implementing this extra step would be site performance.

Also, in relation to additional CSS classes (0003735), I included a sample CSS file with a "black" theme.

TimPietrusky

TimPietrusky

2012-06-20 10:25

reporter   ~0032127

I created a Theme Manager plugin, which covers the following of note 0003736:0005368:

  1. You can create you own theme, it won't get overwritten by updates and you can change the theme with your MantisBT backend
  2. You can change the bug colors inside your css with this http://jsfiddle.net/TimPietrusky/7anH3/

The "MantisBT Theme Manager" can be found here http://github.com/TimPietrusky/MantisThemeManager

JanHegewald

JanHegewald

2012-06-22 04:03

reporter   ~0032137

This just looks great! Thanks for this plugin, when I find the time I'm going to play a little bit with the css things.

vboctor

vboctor

2013-11-04 01:56

manager   ~0038435

Adding link to a github fork that UI updates:
https://github.com/emzec/Best-Mantis-theme-updated

atrol

atrol

2013-11-04 05:57

developer   ~0038438

link to a github fork
Unfortunately no fork but a complete new repository

Issue History

Date Modified Username Field Change
2004-04-12 18:10 tazza70 New Issue
2004-04-12 18:22 tazza70 Note Added: 0005368
2004-08-27 13:09 grangeway Relationship added has duplicate 0003686
2006-02-06 07:24 ryandesign Relationship added related to 0004227
2006-02-06 07:25 ryandesign Relationship added has duplicate 0006671
2010-09-28 20:39 daryn Tag Attached: redesign
2012-06-20 10:25 TimPietrusky Note Added: 0032127
2012-06-22 04:03 JanHegewald Note Added: 0032137
2013-11-04 01:56 vboctor Note Added: 0038435
2013-11-04 05:57 atrol Note Added: 0038438
2013-12-02 15:06 atrol Relationship added has duplicate 0016666
2014-11-25 11:38 vboctor Relationship deleted related to 0004227
2014-11-25 11:39 vboctor Assigned To => vboctor
2014-11-25 11:39 vboctor Status new => resolved
2014-11-25 11:39 vboctor Resolution open => duplicate
2014-11-25 11:39 vboctor Relationship added duplicate of 0004227
2014-12-08 02:18 atrol Status resolved => closed