View Issue Details

IDProjectCategoryView StatusLast Update
0005370mantisbtfilterspublic2008-08-05 22:12
Reporterthraxisp Assigned Tothraxisp  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.19.1 
Summary0005370: Add additional standard filter attributes ('not empty')
Description

Like in the Excel Autofilter mechanism it is desirable to be able to specify not only "any" but also "empty" (or "none") and "non empty" as a global criterion for any filter that searches for strings.

This issue was cloned to cover the 'not empty case'

Additional Information

The project I care for needs to select all issues where the value for "fixed in version" has not yet been set. So I have modified our current mantis version to include the attribute "none" in the selection list (similar to the field "Assigned to"). The modification is fairly simple and affects only a few lines in two files: view_filters_page.php and core\filter_api.php.

TagsNo tags attached.

Relationships

duplicate of 0008149 acknowledged New filter option: [Someone] for Assigned to and other filter fields 
related to 0005075 closedthraxisp Add additional standard filter attributes 
has duplicate 0007046 closedvboctor Ability to filter to get issues that have a custom field value as not empty 

Activities

daryn

daryn

2008-08-05 22:12

reporter   ~0019050

Closing as duplicate of 0008149 since i'm working on filters and 8149 has more recent activity.

Issue History

Date Modified Username Field Change
2005-03-21 09:38 thraxisp New Issue
2005-03-21 09:38 thraxisp Issue generated from: 0005075
2005-03-21 09:38 thraxisp Relationship added related to 0005075
2007-05-09 11:51 vboctor Relationship added has duplicate 0007046
2008-08-05 22:11 daryn Relationship added duplicate of 0008149
2008-08-05 22:12 daryn Note Added: 0019050
2008-08-05 22:12 daryn Status new => closed
2008-08-05 22:12 daryn Resolution open => duplicate