View Issue Details

IDProjectCategoryView StatusLast Update
0007020mantisbtcustom fieldspublic2012-03-05 05:54
Reporterkwilliams Assigned Toatrol  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version1.0.0rc5 
Summary0007020: Custom field can become a parameter in an HTML link
Description

Is it possible to include a special type of custom field that, once populated in an issue, becomes a parameter in an HTML link.

This way, for example, one can hyperlink Mantis issues to other data/docs in web-based databases.

Tagsadmin

Relationships

duplicate of 0013180 confirmed Url template custom field 

Activities

ericb

ericb

2006-05-03 14:40

reporter   ~0012775

Great idea. I would use that too to reference documents in other systems. For example, hardware uses a custom defect tracking system. Given a standard ULR I could just append the defect number that the user entered to the URL. The same would work for specification and memo systems.

silfreed

silfreed

2007-05-29 14:25

reporter   ~0014651

Vote +1; This would be a great feature for linking to other bug systems or other projects' bug trackers.

I currently have the situation where I have my own mantis installation for my software but bugs are being filed in Debian's bug tracker for bugs in my software; I'd like to open bugs in my database and link to the bug reports on Debian's bug tracker.

Perhaps this could be resolved for all custom fields by adding a "Display As" selection that could be: raw value, URL.
When URL is selected, a new option could appear to enter the URL to create.

By separating the value from the display we can still search on the raw value easily but display the value in a different format.

Issue History

Date Modified Username Field Change
2006-05-03 10:51 kwilliams New Issue
2006-05-03 14:40 ericb Note Added: 0012775
2007-05-29 14:25 silfreed Note Added: 0014651
2011-12-20 09:11 atrol Relationship added duplicate of 0013180
2011-12-20 09:11 atrol Status new => resolved
2011-12-20 09:11 atrol Resolution open => duplicate
2011-12-20 09:11 atrol Assigned To => atrol
2011-12-30 10:02 atrol Status resolved => closed
2012-03-05 05:54 mantislee Tag Attached: admin