View Issue Details

IDProjectCategoryView StatusLast Update
0007326mantisbtcustomizationpublic2006-09-12 00:54
ReporterBenBE Assigned Toryandesign  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version1.0.0 
Summary0007326: Use a Templating System to produce Page Output
Description

As many webmasters like to integrate other persons software into their homepage it would be nice if these modifications would not require them to edit within the softwares code files rather than modifying external "Layout Files" containing the prepared source code to render into.

This kind of page templating ist used in a broad range of software like Joomla!, phpBB, and a lot other systems, but AFAIK not in Mantis.

Therefore it would be nice if future versions could make use of external templates instead of hardcoding the output inside the file. Furthermore this helps separating the code from the layout and this way helps customizing the overall layout of Mantis.

TagsNo tags attached.

Relationships

duplicate of 0004227 acknowledged Roadmap 1.0 - Templates 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2006-08-02 15:46 BenBE New Issue
2006-08-02 21:26 ryandesign Relationship added duplicate of 0004227
2006-08-02 21:26 ryandesign Duplicate ID 0 => 4227
2006-08-02 21:26 ryandesign Status new => resolved
2006-08-02 21:26 ryandesign Resolution open => duplicate
2006-08-02 21:26 ryandesign Assigned To => ryandesign
2006-09-12 00:54 vboctor Status resolved => closed